Устранение неполадок

Изменение пароля суперпользователя

Описание

В некоторых случаях пароль суперпользователя СРК может быть утрачен (напр., в связи с увольнением сотрудника). В этом случае необходимо изменить пароль суперпользователя.

Решение

Чтобы изменить пароль суперпользователя СРК RuBackup, нужно изменить пароль служебной БД средствами СУБД, а также заменить пароль в конфигурационном файле сервера.

  1. Подключитесь к служебной базе данных, используя пользователя rubackup или postgres.

    sudo -u rubackup psql

    или

    sudo -u postgres psql
  2. Измените пароль пользователя rubackup.

    ALTER USER rubackup PASSWORD '<new-password>';
  3. Измените пароль в конфигурационном файле СРК.

    rb_init --passwd
    RuBackup initialization utility
    Copyright 2018-2022: LLC "RUBACKUP"
    Исключительные права принадлежат ООО "РУБЭКАП"
    Author is Andrey Kuznetsov
    Version: 2.0 Build: 48024de
    password found in /opt/rubackup/etc/config.file
    
    Please enter old password:
    Enter new password:
    Repeat password:
      Copy old config file to: /opt/rubackup/etc/config.file.old.2024-Jan-18H16-05-32
    Password was changed successfully

Ошибка локализации в Astra 1.8

Описание

Ошибка локализации в процессе развёртывания СРК на узле под управлением ОС Astra Linux 1.8 или при запуске сервисов СРК RuBackup.

Возможная причина

Неверная конфигурация локали.

Диагностика

Убедитесь, что ошибка связана с конфигурацией локали:

sudo locale

Решение

В случае возникновения ошибки после проверки статуса локали решите её одним из способов:

  • Выполните реконфигурацию локали:

    sudo dpkg-reconfigure locales
  • Запустите сервисы СРК RuBackup с явным указанием локали, например:

    sudo LANG=C LC_ALL=C /opt/rubackup/bin/rubackup_client start
    sudo LANG=C LC_ALL=C /opt/rubackup/bin/rubackup_server start

Аварийное завершение работы сервера

Описание

Аварийное завершение работы сервера RuBackup.

Возможная причина

Переполнение файловых дескрипторов.

Диагностика

Признаком переполнения файловых дескрипторов является наличие сообщения в журналах сервера или в системных журналах:

error:Too many open files

Решение

Для решения проблемы администратору узла сервера RuBackup необходимо увеличить максимальное число (лимит) открытых дескрипторов, а затем перезапустить сервер. Подробнее смотри раздел Настройка ограничения на количество открытых файловых дескрипторов на узле сервера RuBackup.

Ошибка запуска сервиса RuBackup

Описание

Служебная база данных RuBackup на базе СУБД PostgreSQL установлена на отдельном сервере (например, при добавлении в конфигурацию резервного или медиасервера). Возникает проблема запуска сервиса RuBackup.

Решение

  1. Удалите зависимости postgresql.service в параметрах Requires и After в разделе Unit в юнит-файле:

    /opt/rubackup/etc/systemd/system/rubackup_server.service
  2. Перезагрузите менеджер служб для операционных систем на базе Linux:

    sudo systemctl daemon-reload